Project

General

Profile

Task #2088

pt-br.blog.documentfoundation.org permanently issue 504 gateway timeout when updating a post

Added by Olivier Hallot about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
High
Category:
-
Target version:
Team - Pool
Start date:
Due date:
% Done:

0%

Estimated time:
Tags:
URL:

Description

In two different location and ISP providers in Brazil, the blog for pt-br above mentined issues 504 gateway timeout when updating a blog post, or preview a blog post.

This is constant. Turns blog editing unusable.

History

#1 Updated by Florian Effenberger about 1 year ago

  • Assignee set to Christian Lohmaier
  • Target version set to Pool

#2 Updated by Florian Effenberger about 1 year ago

Does this problem persist?
Do you have a similar error on the main TDF blog?

#3 Updated by Florian Effenberger about 1 year ago

  • Status changed from New to Closed

No feedback, and Guilhem raised the process limit, so let's close this for the moment. Let's re-open a ticket when problem reoccurs.

#4 Updated by Christian Lohmaier about 1 year ago

blog VM only has 2 virt CPUs, and doesn't even have xcache.. So it reaches CPU limit.

#5 Updated by Guilhem Moulin about 1 year ago

Cf. thread <> on tdf-staff@.

The timeouts were due to slow SQL INSERT/UPDATE queries, which in turn where caused by slow writes operations on GlusterFS (MySQL was waiting for transaction log to sync on disk, delaying each page load).

Flushing to the OS' file cache seems to solve this. But since it's doesn't hurt either I've also installed xcache and applied some performance optimization tweaks to php5-fpm and MySQL.

Also available in: Atom PDF