Project

General

Profile

Actions

Task #3207

closed

templates.libreoffice.org should redirect to a filtered view of only templates at extensions.libreoffice.org

Added by Adolfo Jayme Barrientos almost 4 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Extensions and Templates
Target version:
Team - Q3/2020
Start date:
Due date:
% Done:

0%

Tags:

Description

In the help we mention this URL to help users get document templates; see https://cgit.freedesktop.org/libreoffice/help/commit/?id=8c7ae43f5361145d88cbd2830e3e2eb802117b5e and issue 2137.

This has regressed since the deployment of the new site. It is not obvious for users how to get templates since, sadly, once again the site is very haphazardly designed. Nobody consulted the design team for mockups apparently.

The URL <templates.libreoffice.org> should work and get you a list of templates, not irrelevant, randomly ordered extensions.


Related issues

Related to Infrastructure - Task #3205: Redirections are needed for new Extensions site, to allow links in existing versions of LO to open correct pagesClosedChristian Lohmaier

Actions
Actions #1

Updated by Florian Effenberger almost 4 years ago

  • Assignee set to Christian Lohmaier
Actions #2

Updated by Adolfo Jayme Barrientos almost 4 years ago

  • Related to Task #3205: Redirections are needed for new Extensions site, to allow links in existing versions of LO to open correct pages added
Actions #3

Updated by Adolfo Jayme Barrientos over 3 years ago

The new URL for just templates is https://extensions.libreoffice.org/?Tags%5B%5D=118

It’s not a friendly URL at all, hence the importance of having an alias such as “templates.libreoffice.org”

Actions #4

Updated by Florian Effenberger over 3 years ago

  • Target version set to Q2/2020

I tend to agree - as a start, we could redirect templates.libreoffice.org to the below URL
Much better though would be a SEO-friendly URL with templates.libreoffice.org and the template name
Cloph, is this doable in Q2 still?

Actions #5

Updated by Christian Lohmaier over 3 years ago

  • Assignee changed from Christian Lohmaier to Heiko Tietze
  • Target version changed from Q2/2020 to Q3/2020

Disagree, I don't want distinction between templates and extensions anymore, only will reintroduce this artificial split if I'm "forced" to. Assigning to Heiko first to come to final decision, but I'm strongly against reintroducing the split. There are much better ways to handle this, e.g with the already planned "weighing" of tags and similar.

Actions #6

Updated by Adolfo Jayme Barrientos over 3 years ago

I don't want distinction between templates and extensions anymore

But they ARE different things. Manuals are also NEITHER templates NOR extensions, yet they are hosted in the same site. This is confusing to users.

It’s okay if you want to host all of templates, extensions and manuals in the same infrastructure, just don’t pretend they are the same thing because they aren’t.

Actions #7

Updated by Heiko Tietze almost 3 years ago

  • Status changed from New to Closed
  • Assignee deleted (Heiko Tietze)

We discussed this request in the team meeting and it's a duplicate of rdm#3229.

Actions #8

Updated by Heiko Tietze almost 3 years ago

Btw, any link from LibreOffice should use the hub.libreoffice.org/* scheme now.

Actions

Also available in: Atom PDF