Project

General

Profile

Task #3260

Localized Extension Site Availability

Added by Rizal Muttaqin 8 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Target version:
Team - Q3/2020
Start date:
Due date:
% Done:

0%


Description

Currently using LibreOffice with Bahasa Indonesia (Indonesian) locale and the Extension button in start center point to https://extensions.libreoffice.org/id which is non-existent by now. I don't know in the previous extension how this handled but the URL either should be fixed in the core or we provide appropiate localized extension?

History

#1

Updated by Florian Effenberger 8 months ago

  • Assignee set to Christian Lohmaier
#2

Updated by Heiko Tietze 8 months ago

Request is to localize the extension site itself. It was one of the main goals and we definitely should do that. The current solution is to show a list of options in the main navigation (en fr de it...) but this takes a lot of space and scales badly. I would suggest to add a dropdown in the header but ultimately it needs to align with the whole website.

If users try to access a localized page directly, whether per de.extensions.libreoffice.org or extensions.libreoffice.org/de, and the page is not accessible we should redirect to the main page. Ideally with a note there, perhaps via infobar "The page you were looking for doesn't exist".

#3

Updated by Christian Lohmaier 8 months ago

  • Target version set to Q3/2020

note that the initial report (caused by the hardcoded URLs in LO is different from providing the site in translated form.

For the first I'll hook into the 404 handler and add a custom redirect for those languages that don't have a translation, and for having the site appear translated the strings will be added to weblate for translation.

As for picking the language - first choice will be browser-language-accept string, and only way to deal with lots of languages will be a dropdown.

#4

Updated by Christian Lohmaier 7 months ago

  • Status changed from New to Resolved

static strings were uploaded to weblate for translation (part of website project)

#5

Updated by Florian Effenberger 6 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF