Project

General

Profile

Task #414

AskBot improvements

Added by Florian Effenberger over 3 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Category:
Askbot
Target version:
Team - Qlater
Start date:
Due date:
% Done:

0%

Estimated time:
Tags:
URL:

Description

TDF has decided to fund certain AskBot improvements. This task is to coordinate which ones to fund next.

1) per-language related questions - 2h

7) better facility to deal with the duplicates - 20h
when you mark question as duplicate there will be a UI to find
duplicate questions and mark them.
Forbid asking questions with exact duplicate titles.

12, 13) - the same issue + many other string settings are not localizable - 20h
make string-type settings localizable. The UI will allow entry of string
for each enabled language if the site is multilingual

14 - 16) are related issues (50h total)
The solution is to allow users have one profile per language
and migrate all user profile info into those language settings.
14) make user status separate for each localized instance
-- allow users to have one profile per language-
15) make user list show per language
16) karma per localization

17) list tags per localization - 10h
18) document how to create new localizations - 1h

  • question NEEDINFO tag / status (#687)
  • Generalized mechanism for common question-modifying 'actions' in Askbot (#690)
  • Original question author not displayed for wiki-style question (#700)
  • mark the fields on the profile page as not-to-be-indexed by search-engines
  • verify proper sitemap with Google Webmaster Tools

Further ideas and proposals referenced as tickets.


Related issues

Related to Infrastructure - Feature #690: ASKLIBREOFFICE: Generalized mechanism for common question-modifying 'actions' in AskbotFeedback

Related to Infrastructure - Bug #700: ASKLIBREOFFICE: Original question author not displayed for wiki-style questionFeedback

Related to Infrastructure - Feature #687: AskBot question NEEDINFO tag / statusFeedback

Related to Infrastructure - Feature #370: Add language-picker to AskBotNew

Related to Infrastructure - Bug #699: ASKLIBREOFFICE: All new user content flagged for moderation, and no option to filter by languageNew

Related to Infrastructure - Bug #1407: ASKLIBREOFFICE: Better admin tools for dealing with user accounts?New

Related to Infrastructure - Task #1775: AskBot OpenID problemsRejected

Related to Infrastructure - Task #1683: AskBOT SEO/Sitemap management requiredClosed

Related to Infrastructure - Task #1756: Notification on ask.libreoffice.org no longer worksClosed

Related to Infrastructure - Bug #644: ASKLIBREOFFICE: Japanese site transliterates question URLs incorrectlyRejected

Related to Infrastructure - Task #1624: RSS feed announces new questions although not moderated(?)New

Related to Infrastructure - Task #1825: Askbot Password Reset not workingRejected

History

#1 Updated by Florian Effenberger over 3 years ago

list tags per localization has been incorporated now. Olivier, please let me know if there are any problems. I will now order

better facility to deal with the duplicates - 20h

As next item, so we can gradually grow the tasks.

#2 Updated by Florian Effenberger over 3 years ago

Blocking on Evgeny again, trying to push him a bit to be faster...

#3 Updated by Florian Effenberger over 3 years ago

Poked Evgeny again - this is tedious, but we have no one else at hand, I fear

#4 Updated by Florian Effenberger over 3 years ago

Evgeny promised deployment of next item by Saturday, let's see

#5 Updated by Florian Effenberger over 3 years ago

Item deployed, handing over next task to him when he has time

#6 Updated by Florian Effenberger over 3 years ago

  • Description updated (diff)

#7 Updated by Florian Effenberger over 3 years ago

Now ordered

12, 13) - the same issue + many other string settings are not localizable - 20h
- make string-type settings localizable. The UI will allow entry of string
for each enabled language if the site is multilingual

#8 Updated by Florian Effenberger over 3 years ago

  • % Done changed from 0 to 50

#9 Updated by Florian Effenberger over 3 years ago

  • Description updated (diff)

#10 Updated by Florian Effenberger over 3 years ago

Added one item: Double opt-in, so we can support e-mail login instead of third-party ID services; waiting for his estimation what this costs

#11 Updated by Florian Effenberger about 3 years ago

  • Tracker changed from Feature to Task

#12 Updated by Florian Effenberger about 3 years ago

  • Description updated (diff)

Added a couple of new items to the description

#13 Updated by Florian Effenberger almost 3 years ago

Followed-up with him about double opt-in and e-mail authentication, plus #14-16 -> e-mail done, rest see separate comment

#14 Updated by Florian Effenberger almost 3 years ago

  • Related to Feature #690: ASKLIBREOFFICE: Generalized mechanism for common question-modifying 'actions' in Askbot added

#15 Updated by Florian Effenberger almost 3 years ago

  • Related to Bug #700: ASKLIBREOFFICE: Original question author not displayed for wiki-style question added

#16 Updated by Florian Effenberger almost 3 years ago

  • Related to Feature #687: AskBot question NEEDINFO tag / status added

#17 Updated by Florian Effenberger almost 3 years ago

  • Related to Feature #370: Add language-picker to AskBot added

#18 Updated by Florian Effenberger almost 3 years ago

Now ordered

14 - 16) are related issues (50h total)
The solution is to allow users have one profile per language
and migrate all user profile info into those language settings.
14) make user status separate for each localized instance
- allow users to have one profile per language
15) make user list show per language
16) karma per localization

ETA ~1,5 months from now on

#19 Updated by Florian Effenberger over 2 years ago

Asked Evgeny about the status

#20 Updated by Florian Effenberger over 2 years ago

Update: "I haven't started working on those yet, will try to deliver at least two items by the end of May."

#21 Updated by Florian Effenberger over 2 years ago

Poked Evgeny again

#22 Updated by Florian Effenberger over 2 years ago

"I am working on these features currently and will update you within a week."

#23 Updated by Florian Effenberger over 2 years ago

  • Related to Bug #699: ASKLIBREOFFICE: All new user content flagged for moderation, and no option to filter by language added

#24 Updated by Florian Effenberger over 2 years ago

  • Related to Bug #1407: ASKLIBREOFFICE: Better admin tools for dealing with user accounts? added

#25 Updated by Florian Effenberger about 2 years ago

  • Project changed from Foundation to Infrastructure
  • Subject changed from handle AskBot improvements to AskBot improvements
  • Description updated (diff)
  • Category set to Askbot
  • Target version set to Q4/2015
  • % Done changed from 50 to 0

Poking Evgeny again

#26 Updated by Florian Effenberger about 2 years ago

Poking Evgeny again...

#27 Updated by Florian Effenberger about 2 years ago

Sorry I've been putting this off because of dealing with 
emergencies like spam attacks, etc.
These items are next on my list now, I hope to finish this month.

#28 Updated by Florian Effenberger about 2 years ago

  • Description updated (diff)

#29 Updated by Florian Effenberger about 2 years ago

  • Description updated (diff)

#30 Updated by Florian Effenberger about 2 years ago

  • Target version changed from Q4/2015 to Q1/2016

Poked Evgeny again. Some tasks will surely not be finished in Q4, so postponing to Q1. Nothing really urgent, most critical things have been implemented already.

#31 Updated by Florian Effenberger about 2 years ago

Feedback received:

Working on these items, will be delivered this year.

#32 Updated by Florian Effenberger almost 2 years ago

  • Related to Task #1775: AskBot OpenID problems added

#33 Updated by Florian Effenberger almost 2 years ago

  • Related to Task #1683: AskBOT SEO/Sitemap management required added

#34 Updated by Alexander Werner almost 2 years ago

  • Related to Task #1756: Notification on ask.libreoffice.org no longer works added

#35 Updated by Alexander Werner almost 2 years ago

  • Splitting large sitemap.xml and server-side caching of sidemaps to increase visibility

#36 Updated by Alexander Werner almost 2 years ago

  • Related to Bug #644: ASKLIBREOFFICE: Japanese site transliterates question URLs incorrectly added

#37 Updated by Alexander Werner almost 2 years ago

  • Related to Task #1624: RSS feed announces new questions although not moderated(?) added

#38 Updated by Florian Effenberger almost 2 years ago

  • Assignee changed from Florian Effenberger to Alexander Werner
  • Target version changed from Q1/2016 to Q2/2016

Shifting to Alex to oversee this
Alex, we do not have further budget assigned yet for outstanding items, so let's talk through this in one of the next calls
Basically, you should wear the hat on feature implementations needed and discuss with the budget holders, plus oversee bug fixing like you just did :-)

#39 Updated by Alexander Werner almost 2 years ago

  • Related to Task #1825: Askbot Password Reset not working added

#40 Updated by Florian Effenberger almost 2 years ago

Some further proposal:

I didn't know where to place this suggestion on the Redmine page but I
recently experienced a problem with LibreOffice Ask: When I submit a
post and it gets rejected because it's a duplicate. In the email that
gets sent to me, it should contain a link to the post that it is a
duplicate of. I asked the question because I don't know the answer (Or
If I don't know which search terms to use to find my answer). If I was
a super beginner user of Libreoffice I would be very unhappy receiving
that email. 
[..]
I can't find the answer because the search terms that I use are
probably not the ones I should be using.

I search for :"Libreoffice extension difference macro library" and
"libreoffice extension vs macro library" which don't give me the
answer.

In that rejection email it should have a link the post it was a duplicate of. 

#41 Updated by Florian Effenberger over 1 year ago

  • Description updated (diff)
  • Status changed from In Progress to Feedback

14-16 carried out, rest pending board feedback/budget approval

#42 Updated by Florian Effenberger over 1 year ago

  • Target version changed from Q2/2016 to Qlater

#43 Updated by Florian Effenberger about 1 year ago

  • Assignee changed from Alexander Werner to Florian Effenberger

#44 Updated by Florian Effenberger 9 months ago

  • Status changed from Feedback to Closed

Lots of stuff implemented, no additional budget for AskBot this year, so closing this meta-ticket now

Also available in: Atom PDF