Project

General

Profile

Task #2019

Wiki, update ReCaptcha on production and new wiki

Added by Jan Iversen over 1 year ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Wiki
Target version:
Team - Pool
Start date:
Due date:
% Done:

0%

Estimated time:
Tags:
URL:

Related issues

Related to Infrastructure - Task #2005: wiki migration to VMClosed

History

#1 Updated by Jan Iversen over 1 year ago

  • Subject changed from Wiki, update ReCaptcha to Wiki, update ReCaptcha on production and new wiki
  • Category set to Wiki
  • Assignee set to Jan Iversen
  • Target version set to Pool

Mail copy:

Betreff: [MediaWiki-l] [ConfirmEdit][ReCaptcha] Call-to-Action:
ReCaptcha module will be removed in the near future
Datum: Thu, 4 Aug 2016 23:04:42 +0200
Von: Florian Schmidt <>
Antwort an: MediaWiki announcements and site admin list
<>
An:

Hi all together,

first of all: If you don't use ConfirmEdit with the ReCaptcha (NOT the
ReCaptchaNoCaptcha) module, you can STOP reading here :)

TL;DR

Please upgrade to the ReCaptchaNoCaptcha module to use a supported version
in the future and please respond to [1], if you've an opinion about the
deprecation/removal plan(s).

Long version:

As you may know, ConfirmEdit2 (the MediaWiki extension that helps you to
fight against spam) supports different CAPTCHA modules, such as a
MathCaptcha (where the user has to solve a math problem) or QuestyCaptcha
(where the user has to answer a pre-defined question). Another module is
Google's ReCaptcha3[4], in both versions, the old v1 and the newer v2
(also called NoCaptcha). In December 2014, Google announced a new version of
the ReCaptcha CAPTCHA-service, called ReCaptcha NoCaptcha (or ReCaptcha v2).
ConfirmEdit currently supports both versions, as Google did the same until
recently. Now, as you can read on the FAQ page of ReCaptcha5, Google
stopped supporting the v1 of ReCaptcha. This means, that no new features are
developed and that new keys registered for ReCaptcha will work with the new
version 2 only. This let me come to the conclusion, that ReCaptcha v1 will
not be supported by Google at all anymore in the near future. In order of
this, we should ask our self, how long we want to support the old ReCaptcha
module in ConfirmEdit (which, compared to the NoCaptcha module, seems to
be less effective). The mid-term plan is clear: remove the old ReCaptcha
module. Now there are two ways to achieve this:

  • Deprecate the old reCaptcha in Version 1.27 of MediaWiki (would be a
    so called backport) and remove it in the upcoming 1.28 release
  • Deprecate the old reCaptcha in the upcoming Version 1.28 of
    MediaWiki and remove it:
  • in MediaWiki 1.29 or
  • when Google doesn't support the old reCaptcha anymore

Because this is a huge problem for existing third-party wikis (and because
we don't have any usage statistics), I'm not sure, which plan we should
choose. That's why I sent this e-mail out, to get (hopefully) some responses
and opinions.

So, the call-to-Action: If you still use the old ReCaptcha module, please
plan to upgrade to the new version 2 of ReCaptcha as soon as possible and
let us know (the best way is a comment in the task1), if you need the old
ReCaptcha version supported as long as Google supports it, or if you're fine
with removing it in the upcoming 1.28 release of MediaWiki.

To be absolutely clear: The ReCaptcha module will be removed, the only
question is when: in MediaWiki 1.28 or in MediaWiki 1.29.

If you've any questions, feel free to answer to this e-mail, add a comment
to the linked task, contact me in IRC or write me an e-mail (if you need a
private conversation).

Thanks for your attention and for using ConfirmEdit!

#2 Updated by Jan Iversen over 1 year ago

  • Related to Task #2005: wiki migration to VM added

#3 Updated by Jan Iversen over 1 year ago

Controlled production Wiki. We have no advantage of updating reCaptcha on this platform, but we need to update (maybe use a different) on the new wiki

#4 Updated by Jan Iversen 9 months ago

  • Status changed from New to Closed

Also available in: Atom PDF