Project

General

Profile

Task #1868

Feature #689: Badges

Month of LibreOffice contribution

Added by Bjoern Michaelsen about 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Team - Q2/2016
Start date:
Due date:
% Done:

0%

Estimated time:

Description

So there is lots of discussion and contributions about badges on #689, how ever we didnt get anything off the ground. I'd suggest to rethink this in a [https://en.wikipedia.org/wiki/Minimum_viable_product minimum viable product] fashion and try to get something small, lean and mean that we actually can put up the resources for and that we can get the visibility and marketing in place for. Thus we need to limit the scope. As such I suggest to do this timeboxed instead of going for something 24/7/365 running for eternity and start with a set of no more than 10 badges.

So:
  • Lets timebox this on one month, soon, but not before GSoC is sorted out, so: May or June 2016. Those months are usually slower LibreOffice news wise anyway.
  • Lets limit this in scope to 10 Badges, for example:
    • Barnstar https://redmine.documentfoundation.org/issues/689#note-11
    • Advertised LibreOffice on social media (likely need a wikipage like for barnstars, see below)
    • Comfirmed a bug report independently
    • Bibisected a regression
    • Installled and ran a daily build of LibreOffice and verified a bugfix
    • Commited a code change to LibreOffice
    • Completed an EasyHack with difficulty "beginner"
    • Completed an EasyHack with difficulty "interesting"
    • Translated/Localized a string for the LibreOffice UI
    • Helpfully answered a question on ask.libreoffice.org
  • Have a blogpost on the TDF blog announcing the start of the "Month of LibreOffice contribution" on the last day of the preceeding month -- showing the badges that can be earned.
  • Have a blogpost on the TDF blog announcing the end of the "Month of LibreOffice contribution" and have two (wiki?)pages:
    • One showing each badge, with a list of people who earned that badge
    • One showing a "high score list" showing all people sorted by number of badges earned. (Ideally have social media links in there, so people can share their achievement on g+/twitter/facebook)

For the Barnstars we should have a central wikipage e.g. https://wiki.documentfoundation.org/Barnstars/2016-05 and let people add a signed "I {name} award a barnstar in May 2016 to {name} for {good deed}.". Having them on personal wiki pages would be too much work to collect. For the first run, all the non-barnstar badges should be for actions that can be extracted without much pain from our tooling, so that we dont bog ourselves down with datamining.

In total we need:
  • 9 easily verifiable/measurable goals
  • a barnstar wiki page
  • 10 badge icons
  • someone collecting the data in the end
  • two blogposts

I assume that is in scope for our resources. Once we have this mini run, we can see how to take it from there (doing another event 6 months/12 months later?, switch to an badges thing that runs all the time etc.) .

esc-mentoring.py (11.2 KB) esc-mentoring.py Jan Iversen, 2016-04-15 06:15

History

#1 Updated by Bjoern Michaelsen about 3 years ago

  • Related to Task #1376: month of LibreOffice contribution added

#2 Updated by Bjoern Michaelsen about 3 years ago

(Adding JanIV for considering the ways to measure/list/extract the conditions for the badges. Adding Mike for the blogposts maybe and because this is close to #1376. Adding K-J as he already championed some good stuff at https://wiki.documentfoundation.org/Design/Whiteboards/Badges#Proposal_by_User:k-j . Adding Floeff as discussed on phone.)

#3 Updated by Mike Saunders about 3 years ago

Yes, I can take on the blogging, wiki and social media aspects of this.

#4 Updated by Mike Saunders about 3 years ago

  • Assignee set to Mike Saunders

#5 Updated by Florian Effenberger almost 3 years ago

  • Due date set to 2016-05-02
  • Target version set to Q2/2016

#6 Updated by Mike Saunders almost 3 years ago

  • Status changed from New to In Progress

Started working on this here with some assets and a schedule:

https://wiki.documentfoundation.org/Marketing/Month_of_LibreOffice

Will fill out more next week and get input (especially about which data we can get automatically for the badges)

#7 Updated by Mike Saunders almost 3 years ago

Fleshed out https://wiki.documentfoundation.org/Marketing/Month_of_LibreOffice with more information, schedule, social media approach, banner and first draft of the announcement blog post. Also created first version of Barnstars page at https://wiki.documentfoundation.org/Barnstars/2016-05 – so it's call coming together into a full campaign. Now looking into what we can automate to award Badges without (too much) manual input.

#8 Updated by Beluga Beluga almost 3 years ago

Mike Saunders wrote:

Now looking into what we can automate to award Badges without (too much) manual input.

We can't automate analysis of stuff that people do in Bugzilla.

#9 Updated by Mike Saunders almost 3 years ago

Beluga Beluga wrote:

We can't automate analysis of stuff that people do in Bugzilla.

Thanks for the information. It looks like quite a few badges will have to be done manually, ie updated every day. Beluga, is there a page or view on Bugzilla I can use to see all recently confirmed bugs? If it's 20 or 30 a day that's doable manually -- I could then update the badge list on the site in 10 or 20 mins or so.

Also, is there anything else you think is easy to process and for which we could award QA badges?

#10 Updated by Jan Iversen almost 3 years ago

For sure it can be automated, I pull this information every morning using a script.
Look in the files after "getEasyhack" and "getGerrit".

I do however see it unwise to give badges for closing bugs, we should instead give badges for a patch merged to master, that is the real measure.

In case you decide to give badges for closing easy hack, I need to invent something not to demotivate the contributors who got patches merged on easy hacks that was not closed (due to being designed as long runners).

#11 Updated by Bjoern Michaelsen almost 3 years ago

Mike Saunders wrote:

Beluga, is there a page or view on Bugzilla I can use to see all recently confirmed bugs? If it's 20 or 30 a day that's doable manually -- I could then update the badge list on the site in 10 or 20 mins or so.

https://bugs.documentfoundation.org/buglist.cgi?bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&bug_status=RESOLVED&bug_status=VERIFIED&bug_status=CLOSED&bug_status=NEEDINFO&bug_status=PLEASETEST&chfield=bug_status&chfieldfrom=-30d&chfieldto=Now&chfieldvalue=NEW&list_id=604364&product=LibreOffice&query_format=advanced

^^ A list of all bugs that changed their state to NEW (presumably/hopefully from UNCONFIRMED) in the last 30 days. If you click "edit search" you will find "Search By Change History" at the bottom, where the magic happens. Note the "csv" link on the bottom of the query result -- that link can be used for scripts. see e.g. https://gerrit.libreoffice.org/gitweb?p=dev-tools.git;a=blob;f=scripts/regression-hotspots.py;h=c821a2e90eb093eaf1b22afefb9d930e7c3f2698;hb=5f231ff8263565988470f7fbedb90ff3a4883174 for an example.

Should there be something that isnt queriable with bugzilla directly there is still:

https://lists.freedesktop.org/archives/libreoffice-bugs/

which has one mail for every change to any bug. This can be grep'ed/sed'ed/python'ed/perl'ed to torture out more info out of Bugzilla. see e.g. https://gerrit.libreoffice.org/gitweb?p=dev-tools.git;a=blob;f=scripts/qawrangler-stats.py;h=87b123a185cd456c7c95a5fca9bd05e301849eb3;hb=aee16a14dd5c13c23659b031fac3cef4852b6008.

Finally you can use URLs like https://bugs.documentfoundation.org/show_bug.cgi?ctype=xml&id=94152 to get some pseudo-XML, which might be somewhat machine-readable and contains the full change history of the bug.

#12 Updated by Mike Saunders almost 3 years ago

Thanks Bjoern, those are useful links. The plan is really coming together now:

https://wiki.documentfoundation.org/Marketing/Month_of_LibreOffice

There are six data sources we can use and badges we can award. Jan Iversen would rather not give badges for resolving Easy Hacks (lots of people can be involved and it can be tough to give the right credit for a fix), and a lot of stuff is not easy to automate. But with that plan I should be able to just spend half an hour each day updating the lists and using a bot to generate badges on the wiki.

#13 Updated by Bjoern Michaelsen almost 3 years ago

(adding Simon as e.g. Barnstars where his baby -- just that he is aware what we are doing with that)

#16 Updated by Mike Saunders almost 3 years ago

First week is done with 152 badges and some activity on social media. Also had an article on Softpedia. Current publicity channels:

  • TDF Blog
  • Twitter
  • Facebook
  • announce@ list
  • IRC channels
  • Other mailing lists

The barnstars idea hasn't taken off though. Will keep trying to promote this week, and maybe remove to concentrate on badges if it looks like it's going nowhere...

#17 Updated by Florian Effenberger almost 3 years ago

  • Due date deleted (2016-05-02)

#18 Updated by Mike Saunders almost 3 years ago

In the final week of this now. 290 badges awarded, with some people sharing theirs on social media. Good demonstration of the level of activity within the project, and that it's possible to contribute in many areas (not just code).

After the campaign, I will encourage people to show off their badges, and I'll also write up a report for the TDF blog with lots of stats.

Barnstars is only up to 7 – not really worked in this campaign. That may be worth running on a longer basis rather than trying to cram it in to one month.

#19 Updated by Mike Saunders almost 3 years ago

  • Status changed from In Progress to Closed

OK, this is finished! Here are the results: https://blog.documentfoundation.org/blog/2016/06/02/month-of-libreoffice-may-2016-the-results/

This will be easy to repeat later in the year, or at any other time by a Native Language Project. Here are some thoughts that I also sent to the marketing-priv list:

BADGES

We awarded 341 badges in total: https://wiki.documentfoundation.org/Badges/2016-05

At first I was a bit concerned that the growth would slow to a crawl once regular contributors had all been added, but it was actually very steady throughout the month: https://blog.documentfoundation.org/wp-content/uploads/2016/06/month_of_libreoffice_badges.png

That's a positive sign I think. One challenge is determining how many of the winners contributed for the first time in May, and seeing how long they stay around in the future. In any case, we've seen some people Tweeting their badges, and in the blog post I'll encourage everyone who got one to proudly share it with the world.

We offered six badges this time; we could do more in the future, but it would help to automate data collection. Various people in different areas of the LibreOffice project said that automating is difficult or impossible -- but with only six badges in this case, it wasn't too much work (20 mins per day). All I needed to do was add names to text files when I saw people contributing in a certain area and my script generated the wiki page.

BARNSTARS

This got off to a slow start, but reached 22 by the end of the month: https://wiki.documentfoundation.org/Barnstars/2016-05

I probably should have spread awareness about it across various teams and projects earlier, maybe a week or two before the campaign started. But I saw it being mentioned in the ESC calls (thanks!) which helped.

One thing we could try next time is a simpler system to award Barnstars. Having to log in to the wiki, copy and paste markup and change text is a bit fiddly if you just want to credit someone for their work. I could create a simple form that lets people type in the name and why they get a Barnstar -- we just have to be careful that it doesn't get abused by random people on the net...

#20 Updated by Florian Effenberger over 1 year ago

  • Related to deleted (Task #1376: month of LibreOffice contribution)

Also available in: Atom PDF