Project

General

Profile

Actions

Task #3604

closed

Extensions installation instructions

Added by Jean-Francois Nifenecker over 1 year ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Target version:
-
Start date:
Due date:
% Done:

0%

Tags:

Description

Hello,

I recently directed people to LibreOffice extensions so that they may enhance their "user experience" ;)

I then had to give them directions on how to install the extension because they couldn't find any on the pages they visited.

Today, I've checked that point and can confirm that someone willing to get an extension is let in the dark on the installation process. The way to do that is buried deep on the main LibreOffice website (and in French-only wiki pages, for the best of my knowledge), but cannot be found on the Extensions pages (nor in English).

My suggestion would be to Add a direct link on the Extensions web page_S_ so that downloading and installing is an easy process for the newcomer. Please do NOT add that to the About link, which buries things away.

Thanks in advance,
--
Jean-Francois Nifenecker

Actions #1

Updated by Heiko Tietze over 1 year ago

Are you aware of the "tight integration"? Extensions like templates, icons, galleries can be loaded from where you run it in the program. For example, in the Gallery at the bottom right.

Actions #2

Updated by Jean-Francois Nifenecker over 1 year ago

Hello Heiko,

Yes, I am. Though I must admit that 15 years of using OOo then LibO have impacted the way I'm doing things. As for Extensions, I'm used to directly go the extensions website and browse them from there. Second, the tiny links are probably not appearing in many people's radar (my case :( ).

Anyway, my question remains: anyone landing in the extensions website should be instructed how to install them.

Actions #3

Updated by Heiko Tietze over 1 year ago

Anyway, my question remains: anyone landing in the extensions website should be instructed how to install them.

The preferred workflow is by using the tight integration. But nothing to say against a short documentation here. I suggest to make this ticket a duplicate of rdm#3605 or vice versa.

Actions #4

Updated by Heiko Tietze over 1 year ago

We could add a short note like "Some extensions such as templates, color palettes etc. can be installed directly in the application via "tight integration" some more sensible such as macros require you to download and install per extension manager. See help page..." to the page added for rdm#3605. Olivier might have an opinion on this too.

Actions #5

Updated by Jean-Francois Nifenecker over 1 year ago

"Some extensions such as templates, color palettes etc. can be installed directly in the application via "tight integration" some more sensible such as macros require you to download and install per extension manager. See help page..."

Yes, that might be an idea, provided the said sentence is correctly localized so that the user can find the place where to get the "tight integration" link.

Actions #6

Updated by Shantanu Oak about 1 year ago

The people usually double click on the downloaded extension to install, but then they are hit by this bug:

https://bugs.documentfoundation.org/show_bug.cgi?id=117100

Actions #7

Updated by Florian Effenberger about 1 year ago

  • Assignee set to Christian Lohmaier
Actions #8

Updated by Christian Lohmaier 10 months ago

  • Status changed from New to Resolved

added a link to https://help.libreoffice.org/7.5/en-US/text/shared/01/packagemanager.html#hd_id3895382 to the extensions site's about. (tight integration issue is tracked in other bug)

Actions #9

Updated by Florian Effenberger 9 months ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF