Project

General

Profile

Task #2583

Symbol server for Windows again

Added by Timur Gadzo 12 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Team - Pool
Start date:
Due date:
% Done:

0%

Estimated time:
Tags:
URL:

Description

Symbol server for Windows used to be at http://dev-builds.libreoffice.org/daily/master/Win-x86@39/symbols but that is not built anymore.
Should it be at the one that is regularly updated http://dev-builds.libreoffice.org/daily/master/Win-x86@42/symbols?
And so https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg updated.

History

#1 Updated by Xisco Fauli Tarazona 12 months ago

  • Status changed from New to Resolved

Hi Timur,
Thanks for catching this.

I've updated the wiki. This is the conversation from IRC:

<x1sc0> hi cloph, do you think it's possible to provide symbols builds for win again -> https://redmine.documentfoundation.org/issues/2583 ?
<IZBot> redmine: »Symbol server for Windows again« in Infrastructure (Task for unassigned) [New]
<cloph> that is not my box. (and release builds do have symbols)
<x1sc0> ok, thanks
<x1sc0> cloph, so this is not necessary https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg#First_Time_Setup ?
<x1sc0> i mean step 2
<cloph> no, you would still need to add the symstore configuration (i.e. the URL) to use it. Build would be huge if the debug info were part of the local installation.
<cloph> but again a case of mutated wiki page that lost some clarity maybe. http://dev-downloads.libreoffice.org/symstore/symbols is the URL to add for official builds, the other one is only for that tinderbox.
<x1sc0> ok, thanks for the clarification, I would remove it from there then, since it's no longer updated
<x1sc0> s/would/will

Closing as RESOLVED

#2 Updated by Xisco Fauli Tarazona 12 months ago

I've also poked kendy to see whether he plans to build those symbols again...

#3 Updated by Xisco Fauli Tarazona 12 months ago

I've talked to Kendy and he's taking care of the tinderbox. the symbols should be available tomorrow or the day after.
reverting my change in he wiki...

#4 Updated by Timur Gadzo 12 months ago

"he's taking care of the tinderbox"
I'm not clear which, if 39 then OK, if 42 then I guess we'll have to change in wiki.

#5 Updated by Xisco Fauli Tarazona 12 months ago

Yes, the 39 is Kendy's machine. He has just confirmed me
I'll keep an eye on the page, if the symbols don't get updated, I'll ping him again...

#7 Updated by Xisco Fauli Tarazona 12 months ago

  • Status changed from Resolved to New

Somehow, I misread the date and I thought they were updated but they're not, Date -> 2017-Nov-01 00:47
Putting back to NEW.
Kendy is restarting the machine to see if they get generated now...

#8 Updated by Timur Gadzo 11 months ago

I see symbols from 16.04. How often should they be updated?
Is it OK to use Win-x86@39/symbols if we use @42 build? That should be clarified in the wiki.

#9 Updated by Timur Gadzo 7 months ago

I don't see this resolved. Please answer my question.

#10 Updated by Florian Effenberger 7 months ago

  • Assignee set to Xisco Fauli Tarazona
  • Target version set to Pool

#11 Updated by Xisco Fauli Tarazona 7 months ago

Most likely this is the machine kendy wants to move away from his place. He's on vacation right now, I'll ask him next week...

#12 Updated by Timur Gadzo 4 months ago

Let me bump this again.
Is backtrace useful enough to push for Win-x86@42 symbols and is it possible to have it?

#13 Updated by Xisco Fauli Tarazona 4 months ago

This ticket is on hold until Kendy ships the bot machine to Dennis

#14 Updated by Xisco Fauli Tarazona about 2 months ago

  • Status changed from New to Closed

The machine is back online at cloph's place waiting until it's finally move to dennis' place. Symbols are back -> https://dev-builds.libreoffice.org/daily/master/Win-x86@39/symbols/

Also available in: Atom PDF