Project

General

Profile

Task #2620

"Windows x86_64 (Vista or newer required)" in the OS list on the download page

Added by Aron Budea over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Team - Pool
Start date:
Due date:
% Done:

0%

Tags:
URL:

Description

Open https://www.libreoffice.org/download/download/ and scroll to the list of Operating Systems.
The "(Vista or newer required)" next to Windows x86_64 is now obsolete, as Windows 7 is the required minimum since LO 6.0.

History

#1 Updated by Florian Effenberger over 1 year ago

  • Assignee set to Mike Saunders
  • Target version set to Pool

Thanks for the report!

#2 Updated by Mike Saunders over 1 year ago

This cannot be changed in the SilverStripe admin interface, but needs to be done directly in the PHP code. I'm not a PHP developer so I'm not sure how it works, but it appears to be defined in mysite/code/DownloadObject.php like so:

        // used by Download page type 
        public static $typenames = array (
                "win-x86"      => "Windows",
                "win-x86_64"   => "Windows x86_64 (Vista or newer required)",
                "mac-x86"      => "Mac OS X (Intel)",
                "mac-x86_64"   => "Mac OS X x86_64 (10.8 or newer required)",
                "mac-ppc"      => "Mac OS X (PPC)",
                "deb-x86"      => "Linux - deb (x86)",
                "deb-x86_64"   => "Linux - deb (x86_64)",
                "rpm-x86"      => "Linux - rpm (x86)",
                "rpm-x86_64"   => "Linux - rpm (x86_64)",
                "box"          => "CD/DVD-images",
                "src"          => "Source code" 
        );

I can change the text there, but LibreOffice 5.4 is still supported and works with Vista I believe, so I don't want to change the text for all releases. And not being a PHP coder, I'm not sure how to make it detect whether it's talking about 5.4 or 6.0...

#3 Updated by Florian Effenberger over 1 year ago

With 6.0 and 6.1 listed, I guess we can proceed?

#4 Updated by Mike Saunders over 1 year ago

OK, done – text now says "Windows x86_64 (Windows 7 or newer required)". Closing ticket.

On a separate note, we should change all instances of "Mac OS X" to "macOS", reflecting Apple's rebranding in 2016. But that's a separate matter and I'll check on the website list first, in case there's the possibility it could break something...

#5 Updated by Mike Saunders over 1 year ago

  • Status changed from New to Closed

Oh, and I've also edited https://www.libreoffice.org/get-help/system-requirements/ now that the 5.x series is not offered.

Also available in: Atom PDF