Project

General

Profile

Actions

Task #3072

closed

https://hub.libreoffice.org/ReleaseNotes/?LOvers=6.4 redirects to the fallback URL on Firefox/Chromium

Added by Guilhem Moulin about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Category:
Hub
Target version:
-
Start date:
Due date:
% Done:

0%

Tags:

Description

Actions #1

Updated by Guilhem Moulin about 4 years ago

  • Subject changed from https://hub.libreoffice.org/ReleaseNotes/?LOvers=6.4 redirects to the fallback on Firefox/Chromium to https://hub.libreoffice.org/ReleaseNotes/?LOvers=6.4 redirects to the fallback URL on Firefox/Chromium
Actions #2

Updated by Sophie Gautier about 4 years ago

Thanks for checking. It would be super great to have it solved for the final release :)

Actions #3

Updated by Guilhem Moulin about 4 years ago

Seems solved by downgrading to HTTP/1.0 in the API sub-request. It's a mystery to me why the use of HTTP/1.1 would cause problems here, at least for Firefox and Chromium but not curl (which uses HTTP/2 too in the original request) nor elinks.

We've used HTTP/1.1 in the subrequest since the segment was deployed in mid-May last year, and judging by https://bugs.documentfoundation.org/show_bug.cgi?id=127401 I guess it was properly tested on “real” browsers. Might be a regression caused by the recent HTTPd upgrade on the wiki box. It certainly has nothing to do with a particular release (6.4 or other) nor language (sl or other).

Since I don't understand the root cause here I'm not closing this issue just yet. Sophie Gautier and Martin Srebotnjak, please confirm that you can't reproduce it :-)

Actions #4

Updated by Guilhem Moulin about 4 years ago

  • Status changed from New to Feedback
Actions #5

Updated by Martin Srebotnjak about 4 years ago

Hi, I can confirm with sl in my browser:
https://hub.libreoffice.org/ReleaseNotes/?LOvers=6.4&LOlocale=sl
now properly redirects to
Slovenian 6.4 RelNotes wiki page.

Actions #6

Updated by Sophie Gautier about 4 years ago

Checked in FR version and redirection is done to the FR release notes. Thanks :)

Actions #7

Updated by Guilhem Moulin about 4 years ago

  • Status changed from Feedback to Closed

Cool thanks, closing this issue then!

Actions

Also available in: Atom PDF