Project

General

Profile

Task #3386

Error on JA donation page when entering extremely small or large amount for Stripe

Added by Shinji Enoki 4 months ago. Updated about 9 hours ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
Team - Q1/2021
Start date:
Due date:
% Done:

0%

Tags:
URL:

Description

1. access to https://ja.libreoffice.org/donate/
2. select "金額を入力して通貨を指定してください"
3. make sure it's in JPY. Enter the amount as "10".
4. enter the Optional Email.
5. check the box for reCAPTHA.
6. Push the [Donate via Stripe] button.

The page does not transition and the source code of the page is displayed


Files

donate01.jpg (39.1 KB) donate01.jpg JA donation page Shinji Enoki, 2020-09-23 14:05
donate02.png (98.3 KB) donate02.png Error screen Shinji Enoki, 2020-09-23 14:06

History

#2

Updated by Stephan Ficht 4 months ago

  • Assignee set to Christian Lohmaier
  • Target version set to Q4/2020

Florian confirmed to assign ticket to Christian with Q4/2020

#3

Updated by Florian Effenberger 3 months ago

Thanks for the report! The debugging output has been removed.
For the 10 JPY donation - we need the equivalent of 1 €, otherwise TDF pays more in fees than the donation, and gets negative income.
Can you draft us a text in Japanese asking people to have a minimum amount for this specific reason?
Then Cloph will implement an error message
Thanks! :)

#4

Updated by Florian Effenberger about 2 months ago

  • Status changed from New to Feedback

Shinji, can you let us know the equivalent of 1 €, that we should set as minimum donation value? :) Thanks!

#5

Updated by Shinji Enoki about 2 months ago

Sorry for late reply
EUR-JPY rate fluctuates, so I think 200 yen or more is good

I suggest the following message:
手数料が1ユーロ程度必要なため、金額を指定される場合は200円以上でお願いします。

#6

Updated by Shinji Enoki 14 days ago

Hi Florian Effenberger,

Could you check my translation message?

I suggest the following message:
手数料が1ユーロ程度必要なため、金額を指定される場合は200円以上でお願いします。

I recommend 200 JPY.
The rate changes every day, so I think it's best to have an easy-to-understand amount.

#7

Updated by Florian Effenberger 12 days ago

  • Target version changed from Q4/2020 to Q1/2021

Thanks a lot, that looks good - and sorry for not replying earlier!
Christian, can you implement that text on the Japanese donate page?

#8

Updated by Florian Effenberger 8 days ago

  • Status changed from Feedback to In Progress
#9

Updated by Christian Lohmaier 3 days ago

  • Status changed from In Progress to Resolved

fixed - special case for JPY with the suggested limit of 200 Yen - done in the form verification stage, before handing over to stripe.

#10

Updated by Florian Effenberger 3 days ago

Shinji, is everything working as expected? :)

#11

Updated by Shinji Enoki about 10 hours ago

I think the small amount problem is fixed.
Christian, Florian, thank you for your fix!

There seems to be a problem even with a large amount of money. Would it be another ticket?

#12

Updated by Florian Effenberger about 9 hours ago

Feel free to add the information to this ticket, then we can have a look :)

Also available in: Atom PDF