Project

General

Profile

Task #624

migrate from WebDAV to SparkleShare

Added by Florian Effenberger over 3 years ago. Updated about 1 year ago.

Status:
In Progress
Priority:
Normal
Category:
-
Target version:
Team - Qlater
Start date:
Due date:
% Done:

0%

Estimated time:
Tags:
URL:

Description

Michael asked to evaluate SparkleShare for the internal WebDAV. There seems to be a solution where a server-side SparkleShare client would help to not break existing processes that heavily rely on WebDAV.
detailed description of a proposal on: https://redmine.documentfoundation.org/issues/524


Related issues

Is duplicate of Infrastructure - Feature #524: Create a concrete _proposal_ on how to use/migrate to git/sparkleshareClosed

Blocked by Infrastructure - Task #1477: pumbaa reinstallationClosed

History

#1 Updated by Bjoern Michaelsen over 3 years ago

  • Is duplicate of Feature #524: Create a concrete _proposal_ on how to use/migrate to git/sparkleshare added

#2 Updated by Bjoern Michaelsen about 3 years ago

  • Status changed from Feedback to New

https://redmine.documentfoundation.org/issues/524 should have a pretty complete proposal and is marked resolved. Thus moving this one from Feedback to New.

#3 Updated by Bjoern Michaelsen about 3 years ago

Florian Effenberger: Any reason for this one to be private? Esp. since the much more detailed 524 is public and links here?

#4 Updated by Florian Effenberger about 3 years ago

Not really, no idea why I marked it private in first place...

#5 Updated by Bjoern Michaelsen about 3 years ago

  • Description updated (diff)

#6 Updated by Bjoern Michaelsen about 3 years ago

  • Private changed from Yes to No

unprivating then.

#7 Updated by Bjoern Michaelsen about 3 years ago

  • Status changed from New to Closed

eh, resolved is not closed, so now doing the latter.

#8 Updated by Bjoern Michaelsen about 3 years ago

  • Status changed from Closed to New

thank you Redmine for keeping two bugstates on duplicates except when closing. Very obvious behaviour, that.

#9 Updated by Florian Effenberger about 3 years ago

  • Tracker changed from Feature to Task

#10 Updated by Florian Effenberger about 3 years ago

  • Assignee deleted (Florian Effenberger)

No feedback, other urgent tasks, removing from my pile for the moment; can always re-open ticket later on

#11 Updated by Alexander Werner about 3 years ago

  • Priority changed from Normal to Low

#12 Updated by Michael Meeks about 3 years ago

Out of interest, why was this on your pile Florian, rather than on Alex's ? and why is it now a low priority ? from my POV that sucks rocks. Surely Alex can do the evaluation, and then train you in how to use it: get this - it is awesomely difficult - you just save your document on your file-system: just like dropbox ;-)

Please re-consider.

#13 Updated by Florian Effenberger about 3 years ago

It was on my pile as I have to heavily rely on WebDAV on a daily basis
and there are quite a few dependencies - any disruption or change here
heavily affects my workflow, so I should be be involved to not run into
unpleasant surprises. Not necessarily doing the setup, but being involved.

My latest information is that it's not as trivial, and Björn raised a
couple of questions in #524 - the "read-only WebDAV" in milestone 2 is a
bit confusing to me, also the linking to gerrit in milestone 1, both of
which is different from what I understood in first place.

Asked quite a few times for feedback to no avail, thus de-prioritized it
for the moment.

Proposal: Quickly talk through it during the next board call I attend (2
weeks), and if considered important, advice on which of my tasks should
be de-prioritized for that to raise priority here.

#14 Updated by Bjoern Michaelsen about 3 years ago

@Floeff: IIRC we decided long ago, gerrit is not an option for hosting the WebDAV stuff (that was your opinion and I am fine with that). So we need to host the git repo standalone, which isnt a big thing anyway.

As for the "WebDAV is read-only" in milestone 2, yes that would mean Floeff needs to install and use Sparkleshare to push his changes. That should be a trivial change, but need Floeff to be prepare for on switchover day.

#15 Updated by Florian Effenberger about 3 years ago

Briefly chatted with Michael, we should talk about it during the next
board call I'm there (if we can't manage before)

I recall that it was mentioned I can continue using as I do now,
Sparkleshare could do all the magic without me needing to use a client,
it is all trivial, so I don't have to change my tooling - so if that
isn't true anymore, it indeed needs some of my time factored in to
change my local tooling

I'm a bit confused now indeed ;-)
Let's defer to the phone, I'll add it to the agenda

#16 Updated by Florian Effenberger about 3 years ago

Björn:

What I need your help with is migrating my rsync script I need for tax advise, which roughly looks like that:

rsync --include '2014*' --exclude '*' -azv /local_repoy/ /taxadvise_repo/

I also need to purge older data for a couple of reasons out of their repository, doing that like

MONTH=$(date +%m|sed 's/^0*//') ; let UPTOMONTH=MONTH-2 ; for ((i=1; i<=$UPTOMONTH; i++)) ; do find /taxadvise_repo/ -name *2014-$i* -exec rm {} \; ; done

Besides the fact that I'm obviously no coder :-) - any advice welcome on how to achieve that with SparkleShare.
In other words: I need to delete existing content from their fileshare, and only sync filenames with the last two, three months in the file name to it, while the main share has all the files.

Note the tax advise can most likely not install a client, but needs to use a web browser with HTTPS.

#17 Updated by Bjoern Michaelsen about 3 years ago

Florian Effenberger wrote:

What I need your help with is migrating my rsync script I need for tax advise, which roughly looks like that:

Sparkleshare (or git) should give you a local copy of the repo anyway.

I also need to purge older data for a couple of reasons out of their repository, doing that like

As you will have a local copy, running the script locally and then pushing the change to the repo (Sparkleshare gives you a nice UI for the latter).

Note the tax advise can most likely not install a client, but needs to use a web browser with HTTPS.

Thats not a problem as they only need to read, not write.

#18 Updated by Florian Effenberger about 3 years ago

  • Due date set to 2015-01-16
  • Assignee set to Alexander Werner
  • Priority changed from Low to Normal

Let's have a test drive mid-January and see the implications then, and go from there

#19 Updated by Florian Effenberger over 2 years ago

  • Target version set to Pool

#20 Updated by Florian Effenberger about 2 years ago

  • Due date deleted (2015-01-16)
  • Target version changed from Pool to Q1/2016

#21 Updated by Alexander Werner almost 2 years ago

  • Status changed from New to Feedback

It is unclear what needs to be done for the concrete evaluation from my side at the moment.

#22 Updated by Florian Effenberger almost 2 years ago

  • Subject changed from evaluate SparkleShare to migrate from WebDAV to SparkleShare
  • Status changed from Feedback to In Progress
  • Assignee changed from Alexander Werner to Florian Effenberger

Directly talked to Alex in the office to finally get this nailed down
We do have a repository that can be used, and I will do the next round of accounting via these means, to see if the interaction with the accountant works that way
Plan is that I feed the documents via git & rsync, accountant gets them via GitLab's web interface
If that works, we deploy that to a machine, migrate the existing WebDAV and change the accounting workflow

#23 Updated by Florian Effenberger almost 2 years ago

  • Target version changed from Q1/2016 to Q2/2016

#26 Updated by Florian Effenberger over 1 year ago

  • Blocked by Task #1477: pumbaa reinstallation added

#29 Updated by Florian Effenberger about 1 year ago

  • Target version changed from Q2/2016 to Qlater

Also available in: Atom PDF