Project

General

Profile

Feature #142

disable invalid e-mail addresses for wiki notifications

Added by Florian Effenberger almost 7 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Wiki
Target version:
-
Start date:
Due date:
% Done:

0%

Tags:
URL:

Description

MediaWiki in the current setup doesn't provide bounce handling for mail notifications. In other words, someone who has an outdated mail address on file will have his message bounced back. This can either be manually fixed in the database, or via some extension. We need to investigate what a sane approach to handling these issues is.

History

#1

Updated by Dennis Roczek almost 7 years ago

Florian Effenberger wrote:

MediaWiki in the current setup doesn't provide bounce handling for mail notifications. In other words, someone who has an outdated mail address on file will have his message bounced back. This can either be manually fixed in the database, or via some extension. We need to investigate what a sane approach to handling these issues is.

Well this seems to be a GSoC, see https://www.mediawiki.org/wiki/Mentorship_programs/Possible_projects#Adding_proper_email_bounce_handling_to_MediaWiki_.28with_VERP.29.C2.A0 and https://bugzilla.wikimedia.org/show_bug.cgi?id=46640

#2

Updated by Alexander Werner almost 7 years ago

  • Assignee set to Alexander Werner
#3

Updated by Alexander Werner over 6 years ago

Deferred until feature is implemented upstream

#4

Updated by Florian Effenberger about 6 years ago

  • Assignee deleted (Alexander Werner)

Removing from Alex pile, as the upstream feature is missing, and this is ideal for new volunteers to get involved later on

#5

Updated by Dennis Roczek about 6 years ago

as send by private mail to alex and floeff:
this extension will be released and some features will be backported (!) to 1.24 (which will be released in 2 days)...

I'm on the CC list from WMF and one of the WMF devs offered me help in setting up the mail config. :-)

Just for the note... ;-)

#6

Updated by Florian Effenberger almost 6 years ago

  • Assignee set to Dennis Roczek

Is there an update already? ;-)

#7

Updated by Dennis Roczek almost 6 years ago

Florian Effenberger wrote:

Is there an update already? ;-)

!trout ;-)

no. I'm helping qubit cleaning the (tdf|help)wiki from fdo links (well and bugs.libreoffice). Should be done relative shortly as we just checking if we have replaced too many links (e.g. peppler links which are still at fdo)

so hopefully i can do work on some wiki configs today / this week :-p

#8

Updated by Dennis Roczek over 5 years ago

Ok, extension is released since a few months and requires 1.19+ :-) (we are using 1.24 currently)

The extension can be found at https://www.mediawiki.org/wiki/Extension:BounceHandler

Florian Effenberger should I still deploy it? what about the SSO migration? Wouldn't it be useful to handle that at the end by the "master instance"?

#9

Updated by Florian Effenberger over 5 years ago

Florian Effenberger should I still deploy it? what about the SSO migration? Wouldn't
it be useful to handle that at the end by the "master instance"?

SSO will take some time - so in case this extension helps our cause, I'm
all for deploying it. Can you check it out and test if it has negative
side effects? Thanks!

#10

Updated by Dennis Roczek over 5 years ago

Florian Effenberger wrote:

Can you check it out and test if it has negative
side effects? Thanks!

OK, extension installed, DB updated. (see https://wiki.documentfoundation.org/Special:Version) That's the good news.

The bad one is, that I totally forgot everything on postfix... :-p
But you are the postfix-guy, or? g See https://www.mediawiki.org/wiki/Extension:BounceHandler#Configuration I have no clue how to deploy that configuration to kermit at the moment. I guess this would be a wonderful task for the postfix workshop. :-p

I guess I will read many documentations to understand that all correctly. ;-)

#11

Updated by Florian Effenberger over 5 years ago

OK, extension installed, DB updated. (see
https://wiki.documentfoundation.org/Special:Version) That's the good news.

Thanks!

The bad one is, that I totally forgot everything on postfix... :-p
But you are the postfix-guy, or? g See
https://www.mediawiki.org/wiki/Extension:BounceHandler#Configuration I
have no clue how to deploy that configuration to kermit at the moment. I
guess this would be a wonderful task for the postfix workshop. :-p

Seems the page only documents this for Exim, but not for Postfix. Can
you maybe google if you find similar instructions for Postfix?

#12

Updated by Dennis Roczek over 5 years ago

Florian Effenberger wrote:
[...]

https://www.mediawiki.org/wiki/Extension:BounceHandler#Configuration I
have no clue how to deploy that configuration to kermit at the moment. I
guess this would be a wonderful task for the postfix workshop. :-p

Can you maybe google if you find similar instructions for Postfix?

will do.
BTW I found some interesting information at
https://wikitech.wikimedia.org/wiki/BounceHandler_Configurations

Main Configuration's
Kept in wmf-config/InitialiseSettings.php
Toggle un-subscribe action:

$wgBounceHandlerUnconfirmUsers = true;
The threshold limit for maximum number of allowed bounces is:

$wgBounceRecordLimit = 5;

I guess we should add the unconfirmed parameter. RecordLimit also at 5?

#13

Updated by Dennis Roczek over 5 years ago

Florian Effenberger wrote:

Seems the page only documents this for Exim, but not for Postfix. Can
you maybe google if you find similar instructions for Postfix?

For the reference: I requested the documentation from the devs of the extension. Tracked at https://phabricator.wikimedia.org/T114252

#14

Updated by Beluga Beluga almost 4 years ago

Dennis Roczek wrote:

Florian Effenberger wrote:

Seems the page only documents this for Exim, but not for Postfix. Can
you maybe google if you find similar instructions for Postfix?

For the reference: I requested the documentation from the devs of the extension. Tracked at https://phabricator.wikimedia.org/T114252

Yep, they created it: https://www.mediawiki.org/wiki/Extension:BounceHandler#Adding_bouncehandler_configuration_to_Postfix

#15

Updated by Dennis Roczek 11 months ago

Guilhem Moulin: Do we still need that? The wiki is attached to th LDAP / SSO now. So I do believe that this is more a task for the LDAP rather than part of the wiki and moreover flagging the mail address unconfirmed in the wiki doesn't do this in LDAP.

What to do now?
Some ideas:
  • Fork the extension for being able to set the flag to LDAP?
  • Remove the extension
  • Let is at is (I really do not know the status except that I do not get any mails by this extensions since ~2 years)

Best regards,

Dennis

#16

Updated by Guilhem Moulin 11 months ago

  • Status changed from New to Closed

The wiki is attached to th LDAP / SSO now.

It's not directly attached to LDAP, and uses SSO only for authentication. If someone changes their email address in SSO it won't be updated to the wiki until the next time they log in. Also, there is currently no boolean attribute in the LDAP schema that would disable notifications.

Remove the extension
Let is at is (I really do not know the status except that I do not get any mails by this extensions since ~2 years)

Hmm we've used VERP since summer 2018, there are 4 bounce records in the database right now. But it appears $wgBounceHandlerUnconfirmUsers was left to the default (false)… That said we'll need 5 bounces in the past 60 days to unsubscribe an account which seems rare (in the past 60 days we received only 4 bounces from 2 different addresses).

Also available in: Atom PDF