Project

General

Profile

Actions

Task #3469

closed

Can't download language pack in Google Chrome on Mac/Linux

Added by Jun Nogata over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Tags:

Description

Using Google Chrome(88.0.4324.192) on MacOS(Catalina/10.15.7)/Linux(Debian Sid) and, there is no response when I click on the language pack link on the download page.

There are other people in the same situation. https://twitter.com/Horita_JAIC/status/1322751144800612353

1. Open Download page (Using Google Chrome on MacOS) https://ja.libreoffice.org/download/download/?type=mac-x86_64&version=7.1.0&lang=ja
2. Click on the "Translated User Interface" link
3. It does not download and there is no response

Actions #1

Updated by Sophie Gautier over 1 year ago

  • Assignee set to Christian Lohmaier

Cloph could you have a look at it please?

Actions #2

Updated by Shinji Enoki over 1 year ago

In my Debian Sid environment, I was able to download it in both Firefox(86.0) and Chromium(88.0.4324.182).

We exchanged information about it at Japanese team meeting. I've heard the following information

In Chrome, it couldn't be downloaded from the language pack link on the download page.
https://ja.libreoffice.org/download/download/?type=mac-x86_64&version=7.1.0&lang=ja
http://download.documentfoundation.org/libreoffice/stable/7.1.0/mac/x86_64/LibreOffice_7.1.0_MacOS_x86-64_langpack_ja.dmg (link)

However, Nogata-san was able to download it from the language pack link on the next page.
https://ja.libreoffice.org/donate/dl/mac-x86_64/7.1.0/ja/LibreOffice_7.1.0_MacOS_x86-64.dmg
https://download.documentfoundation.org/libreoffice/stable/7.1.0/mac/x86_64/LibreOffice_7.1.0_MacOS_x86-64_langpack_ja.dmg (link)

I thought the difference was http and https.

Actions #3

Updated by Guilhem Moulin over 1 year ago

Shinji Enoki wrote:

I thought the difference was http and https.

I guess recent Chrome/Chromium versions refuse to download software when the chain of redirect have a cleartext link, even when the software itself is downloaded from a mirror over TLS.

The browser console likely had some details about why the download didn't proceed. Anyway I upgraded the links now, does it help?

Actions #4

Updated by Christian Lohmaier over 1 year ago

Hmm. Cannot reproduce - the links on the main download-page also is https://download.documentfoundation.org/… for me, and while there can be problems when mirrorbrain hands out a http mirror when coming from https (that's where the download - or rather the protocol downgrade in a redirect - is blocked by the browser), only one mirror in asia region is using http, the others, especially the two in Japan are https, and the one in Indonesia is even limited to only handle request from Indonesia only:

sudo -u mirrorbrain mb list -H -r as --country --country-only
mirror.isoc.org.il             il https://mirror.isoc.org.il/pub/tdf/                     country_only=True
nju.edu.cn                     cn https://mirrors.nju.edu.cn/tdf/                         country_only=False
ftp.kaist.ac.kr                kr https://ftp.kaist.ac.kr/tdf/                            country_only=False
free.nchc.org.tw               tw https://free.nchc.org.tw/tdf/                           country_only=False
ftp.iitm.ac.in                 in https://ftp.iitm.ac.in/tdf/                             country_only=True
koddos.net                     hk https://mirror-hk.koddos.net/tdf/                       country_only=False
freedif.org                    vn https://mirror.freedif.org/TDF/                         country_only=False
kambing.ui.ac.id               id http://kambing.ui.ac.id/tdf/                            country_only=True
ftp.kddilabs.jp                jp https://ftp-srv2.kddilabs.jp/office/tdf/                country_only=False
library.ucy.ac.cy              cy https://mirror.library.ucy.ac.cy/tdf/                   country_only=False
labkom                         id https://mirror.labkom.id/tdf/                           country_only=False
datautama.net.id               id                                                         country_only=False
estointernet.in                in https://mirrors.estointernet.in/tdf/                    country_only=True
download.nus.edu.sg            sg https://download.nus.edu.sg/mirror/tdf/                 country_only=False
ftp.yz.yamagata-u.ac.jp        jp https://ftp.yz.yamagata-u.ac.jp/pub/tdf/                country_only=False

could of course be that the region detection based on the IP fails/that the assignment or IPs changed and it is not reflected int the geolocation database.

But if you can still reproduce, the web-developer console in chrome should provide some more info (ctrl+shift+c on linux, so probably command+shift+c on mac)

so a few things need to be clarified:
Actions #5

Updated by Guilhem Moulin over 1 year ago

Christian Lohmaier wrote:

Hmm. Cannot reproduce - the links on the main download-page also is https://download.documentfoundation.org/

I changed that yesterday, it was http:// before.

Actions #6

Updated by Shinji Enoki over 1 year ago

Thank you for the fix and comments!

We checked it at today's Japanese Team meeting.
It was not reproduced in Chrome in the environment of all four meeting participants including Nogata-san.

I don't know the reason. There is a possibility of the effect of the Gillem's fix or the version upgrade of Chrome, or http mirror server has not been hit.

This doesn't seem to reproduce now,
so I think it's okay to close.

Actions #7

Updated by Guilhem Moulin over 1 year ago

  • Status changed from New to Closed

Quite sure it was because of the cleartext links on the download page

Actions

Also available in: Atom PDF