Project

General

Profile

Feature #107

install MediaWiki translate extension

Added by Florian Effenberger over 4 years ago. Updated 1 day ago.

Status:
Closed
Priority:
Normal
Category:
Wiki
Target version:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Tags:
URL:

Description

We need to install the following extension for our public wiki: https://www.mediawiki.org/wiki/Extension:Translate


Related issues

Blocked by Infrastructure - Feature #465: update MediaWiki to 1.23Closed

History

#1 Updated by Alexander Werner over 4 years ago

  • Assignee set to Alexander Werner

#2 Updated by Alexander Werner over 4 years ago

  • Category set to Wiki

#3 Updated by Alexander Werner about 4 years ago

#4 Updated by Alexander Werner about 4 years ago

Deferred until tested with MediaWiki 1.23

#5 Updated by Dennis Roczek about 4 years ago

#6 Updated by Dennis Roczek about 4 years ago

#7 Updated by Adolfo Jayme Barrientos about 4 years ago

Please consider installing the TranslationNotification extension as well. It would allow translators to be notified via e-mail about important pages that need translation, such as the release notes.

#8 Updated by Robinson Tryon almost 4 years ago

Adolfo Jayme wrote:

Please consider installing the TranslationNotification extension as well. It would allow translators to be notified via e-mail about important pages that need translation, such as the release notes.

+1

It sounds like installing the Language Extension Bundle is the suggested way of setting-up for multilingual wikis:
https://www.mediawiki.org/wiki/MediaWiki_Language_Extension_Bundle

TranslationNotifications is (I believe) a separate extension:
https://www.mediawiki.org/wiki/Extension:TranslationNotifications

#9 Updated by Florian Effenberger over 3 years ago

Any chance to have a look at this before Christmas?

#10 Updated by Dennis Roczek over 3 years ago

well it depend on my time. but for the case alex doesn't have the time, I will likely find the time int he holidays. (so I would only need access, but for that i have to send my sha key... :-P)

#11 Updated by Florian Effenberger over 3 years ago

Feel free to mail your SSH key to Alex, of course ;-)

#12 Updated by Florian Effenberger over 3 years ago

Did you get access already? If not, e-mail me your private key directly

#13 Updated by Alexander Werner over 3 years ago

  • Status changed from New to Feedback
  • Assignee changed from Alexander Werner to Dennis Roczek

Dennis, i need your SSH key please and a password generated with mkpasswd --method=sha-512 or

$ python2
$ import crypt; print crypt.crypt('PASSWORD','$6$HASH')

#14 Updated by Dennis Roczek over 3 years ago

Alexander Werner wrote:

Dennis, i need your SSH key please and a password generated with mkpasswd --method=sha-512 or
[...]

Yeah. Sry. I had some problems with my flat in the last few days and thus my spare time was eaten up. :-(

Will do it later. ;-) (I promise!)

#15 Updated by Dennis Roczek over 3 years ago

@alex and finally here is my ssh :-)

ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQCkkIkLOsDOvwkWSPIxPM+N1OHVV/6Hif4jrupQ/sxZ9ldFuTrT3oruoiuRyQ8T+/1zA7tpyvJYieF4V1JIq1NnMVY9S15e10nG2IwmqnyYZ3kfNkuSP1rl7ynjYPjVRjXK8a6k6llyAQMDt4i2CwGY8GN+sayEuSJ/0w1gjO9vef8HoXaHfPlbK5kO79cjlCaK4grHmoo4mINeWSGZU9OVSjn43+NEZHz3MJZPcHctpsDoQi+EVCpUGyDEcMFEMvZFFOjYKFa5V6xuE1S2BszWmTG90p9Xs5R0+mpgRNNOR6iVNcM8QkEf7NOgLdVzusU7eIRxjtrUAlizYBVWZOpn

#16 Updated by Dennis Roczek over 2 years ago

  • Status changed from Feedback to New

#17 Updated by Beluga Beluga 6 months ago

Robinson Tryon wrote:

It sounds like installing the Language Extension Bundle is the suggested way of setting-up for multilingual wikis:
https://www.mediawiki.org/wiki/MediaWiki_Language_Extension_Bundle

This was requested just now by a contributor, the reason given:
"I’ve noticed that composing and editing Persian, an RTL language, is nearly impossible currently (you have to use several hacks to make it work)."

#18 Updated by Eric Bright 6 months ago

Thank you Beluga and Dennis Roczek for reviving this issue. I certainly need that bundle if I, or any Persian-speaking editor for that matter, want to edit an RTL page.

The problem is that the wiki editor jumbles up everything in the “compose” area from left to right and sentences become almost unreadable there. One has to copy them into an external editor that also supports RTL, edit the text there, copy/paste them back in the wiki editor (which immediately scrambles up everything again), look at the preview, and repeat. It’s a tangled mess!

Not only that, but also any language tag such as {{fa}} {{fa-end}} that one might add to fix the published page, only affects the body part that is manually composed. All other auto-created parts, such as the table of contents, are still LTR in the published page.

#19 Updated by Florian Effenberger about 1 month ago

Dennis, Guilhem, something you can have a look at maybe during next week?

#20 Updated by Guilhem Moulin about 1 month ago

  • Assignee changed from Dennis Roczek to Guilhem Moulin
  • % Done changed from 0 to 90

Done: deployed and tested on test wiki, deployed to prod wiki. (I'll be on vacation starting at the end of the next week, and should problem arise I'd very much avoid getting a phone call during DebConf :-P)

See https://www.mediawiki.org/wiki/Help:Extension:Translate/Page_translation_example for a tutorial. See also the language selector dropdown menu at the top right of the page.

The configuration is pretty minimal at the moment, depending on how it affects the load we'll need to see whether further optimization is needed.

How about ACLs? Should every user be allowed to translate, or should we create a new “translators” group or something?

#21 Updated by Florian Effenberger 11 days ago

How about ACLs? Should every user be allowed to translate, or should we
create a new “translators” group or something?

No educated guess here - can you poke Marina? She asked for that
extension recently, maybe she has an idea :)

#22 Updated by Dennis Roczek 11 days ago

Florian Effenberger wrote:

How about ACLs? Should every user be allowed to translate, or should we
create a new “translators” group or something?

No educated guess here - can you poke Marina? She asked for that
extension recently, maybe she has an idea :)

do everybody (registered) to be open as much as possible; then we can see how this will work out. To restrict the stuff is easy and can be done later for the case it produces vandalism/spam/whatever.

#23 Updated by Florian Effenberger 9 days ago

No objections ;)

do everybody (registered) to be open as much as possible; then we can
see how this will work out. To restrict the stuff is easy and can be
done later for the case it produces vandalism/spam/whatever.

#24 Updated by Guilhem Moulin 1 day ago

  • Status changed from New to Closed
  • % Done changed from 90 to 100

Dennis Roczek wrote:

do everybody (registered) to be open as much as possible; then we can see how this will work out. To restrict the stuff is easy and can be done later for the case it produces vandalism/spam/whatever.

Fair enough, done and closing this :-)

Also available in: Atom PDF