Project

General

Profile

Feature #597

Bibisect (Linux) - 4.4 Build

Added by Joel Madero over 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
High
Category:
QA
Target version:
-
Start date:
Due date:
2014-11-09
% Done:

0%

Tags:
URL:

Description

Bjoern has said he's happy to pass on the bibisect duties to our new QA Engineer. What is needed:

First:
Create 4.4 Bibisect Package:
We don't have a 4.4 package at all - we're starting to get quite a few regressions in 4.4 that we just can't bibisect which is unfortunate. In my opinion this is quite high on the priorities as bibisects are tremendously helpful for moving forward to getting regressions resolved.

This being said - Robinson may need new hardware or to have access remotely to something that can build fast. We have one machine that we might be able to send with him from Bern (Bjoern might be able to bring it) if that's easier/cheaper than purchasing something new. Robinson should contact myself and Bjoern if new hardware will be needed.


Related issues

Related to Infrastructure - Bug #917: 4.4 Bibisect: Configure server to provide builds from Alpha1 - Beta1Closed

Actions

History

#1

Updated by Robinson Tryon over 6 years ago

Joel Madero wrote:

This being said - Robinson may need new hardware or to have access remotely to something that can build fast. We have one machine that we might be able to send with him from Bern (Bjoern might be able to bring it) if that's easier/cheaper than purchasing something new. Robinson should contact myself and Bjoern if new hardware will be needed.

Bjoern: Please tell us more about this particular hardware.

For uptime and bandwidth considerations, I think that something hosted at a colo might be our best bet, but it's definitely worth it for us to have a quick discussion about different potential setups.

#2

Updated by Bjoern Michaelsen over 6 years ago

Robinson Tryon wrote:

Bjoern: Please tell us more about this particular hardware.

Its a Sun Ultra 24 owned by TDF with a Yorkfield C2Q Q9650 4-way CPU and 8GB RAM, which should still be a decent builder machine. As for CoLo, please ask floeff about the details. I just need to know if I should bring that hardware to the conference.

#3

Updated by Robinson Tryon over 6 years ago

I think our best option would be to get the hardware into our colo.

Florian: Sounds like Bjoern can bring the machine to Bern, or can ship it. Let's figure out our plan soon.

#4

Updated by Bjoern Michaelsen over 6 years ago

so because of canonicals travel policies making this easier, I will fly to Bern and not take the train. So I cant bring hardware.
@Flo/Robinson: Please coordinate if the colo can host and then where to sent the hardware.

#5

Updated by Florian Effenberger over 6 years ago

Can you send me specific details on the hardware, so I can check what's
possible?

#6

Updated by Bjoern Michaelsen over 6 years ago

What do you need to know beyond https://en.wikipedia.org/wiki/Ultra_24 ?

#8

Updated by Florian Effenberger over 6 years ago

Poked our new hoster for details

#9

Updated by Bjoern Michaelsen over 6 years ago

  • Status changed from New to Feedback

Florian Effenberger wrote:

Poked our new hoster for details

We now have a quote from the hoster, waiting for approval from the dev budget (mmeeks, Caolán).

#10

Updated by Bjoern Michaelsen over 6 years ago

  • Status changed from Feedback to In Progress
  • Assignee changed from Robinson Tryon to Bjoern Michaelsen

Michael approved budget via Email, if I dont hear back from Coalan by tomorrow, I take that as a lazy consensus and go ahead with Manitu.

#11

Updated by Bjoern Michaelsen over 6 years ago

  • Project changed from 49 to Infrastructure
  • Status changed from In Progress to Feedback
  • Assignee changed from Bjoern Michaelsen to Alexander Werner

Moving to infrastructure as per: https://redmine.documentfoundation.org/issues/599#note-2 (this also enables to assign to Alex)

assigned to Alex: Waiting for an assigned IP for the machine, please reassign back to me, if that is done, I will then install the machine accordingly and send it to manitu.

#12

Updated by Bjoern Michaelsen over 6 years ago

  • Category set to QA
#13

Updated by Bjoern Michaelsen over 6 years ago

  • Due date set to 2014-10-19

setting due date -- next bibisect build is for 4.4 alpha 1, which is due mid-October 2014: https://wiki.documentfoundation.org/ReleasePlan/4.4#4.4.0_release

#14

Updated by Alexander Werner over 6 years ago

  • Assignee changed from Alexander Werner to Bjoern Michaelsen

Oversaw that it was assigned to me, assigning back to Björn as IP was already assigned

#15

Updated by Bjoern Michaelsen over 6 years ago

  • Status changed from Feedback to In Progress

Alexander Werner wrote:

Oversaw that it was assigned to me, assigning back to Björn as IP was already assigned

But is configured, now only need to find a good way to get this delivered.

#16

Updated by Bjoern Michaelsen over 6 years ago

  • Due date changed from 2014-10-19 to 2014-11-09
  • Assignee changed from Bjoern Michaelsen to Robinson Tryon

The box is on the way to the datacenter.

@Robinson: Please take over from here. I will send you the contact of the datacenter guys to solve any remaining open issues.

Also pushing back the due date to mid-November, this is to have the machine ready-to-go when 4.4.0~beta1 comes around. I will still build the alpha1 builds on big Bertha, so QA has something to work with in the meantime.

#17

Updated by Christian Lohmaier over 6 years ago

did some builds in amazon ec2 for comparions - the 8core ones c3.2xlarge / r3.2xlarge can do full-from-scratch ccache-driven builds in on average 20 minutes (build with no changes is ~8 minutes), including adding to bibisect-repo, with close-to-release config (i.e. with all builtin stuff), on Ubuntu 14.04, with changes 16 commits apart

--with-distro=LibreOfficeLinux
--disable-epm
--disable-dependency-tracking
--disable-odk
--enable-gstreamer
--disable-gstreamer-0-10
--disable-kde
--enable-kde4
--with-external-tar=/srv/lo/source/lo-externalsrc

in other words
8 days to build from libreoffice-4-3-branch-point to current master with 16 commits spacing (with 8core variant, there are more powerful ones available)
with spot-pricing (currently pretty stable at a little less than 0.07$/hour): around 13$ (+some cents for storage)

#18

Updated by Bjoern Michaelsen over 6 years ago

Christian Lohmaier wrote:

did some builds in amazon ec2 for comparions

Thats great, but a bit beside the point for this task. We already have this hardware available -- so unless we need it for something else, we should stay with bibisect on this machine. FWIW, I think having this hardware around 24/7 for QA testing/staging isnt a bad thing.

So:great to know we could move bibisect to the cloud, but since we will have the cost of hosting for this box anyway, creating the bibisects there comes essentially for free.

#19

Updated by Florian Effenberger over 6 years ago

Robinson, can you give us a short status update? Will we meet the deadline on this, keeping in mind that #591 has an even higher priority (but earlier deadline)? A short update would be appreciated ;-)
The machine itself seems to be online, at least SSH is responsive, so from the infra POV, we're good to go - if you can quickly update me on where we stand, that'd be appreciated.

#21

Updated by Florian Effenberger about 6 years ago

Update from team call:
Robinson will try to use the machine, and if he needs help, reconnect with Alex and Björn

#22

Updated by Florian Effenberger about 6 years ago

Todo for Robinson: Set up a new ticket, closing this one, with details and deadline end-November, assigned to him

#23

Updated by Robinson Tryon about 6 years ago

  • Status changed from In Progress to Closed

Florian Effenberger wrote:

Todo for Robinson: Set up a new ticket, closing this one, with details and deadline end-November, assigned to him

Done --> See issue #790.

#24

Updated by Robinson Tryon about 6 years ago

  • Related to Bug #917: 4.4 Bibisect: Configure server to provide builds from Alpha1 - Beta1 added

Also available in: Atom PDF